Trac Search Module SQL Injection
Posted on 06 December 2005

Vulnerability Description

Trac contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the search module not properly sanitizing user-supplied input to an unspecified variable. This may allow an attacker to inject or manipulate SQL queries in the backend database.

Solution Description

Upgrade to version 0.9.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Products:

  • Edgewall Software Trac 0.8.4 Affected
  • Edgewall Software Trac 0.9 Affected
  • Edgewall Software Trac 0.8.3 Affected
  • Edgewall Software Trac 0.7.1 Affected
  • Edgewall Software Trac 0.8.1 Affected
  • Edgewall Software Trac 0.9.1 Affected

Vulnerability classification:

  • Remote vulnerability
  • Input manipulation attack
  • Impact on integrity
  • Exploit unknown
  • Verified

External references:

  • Vendor Specific News/Changelog Entry: go there
  • Vendor URL: go there
  • Security Tracker: 1015302
  • Secunia Advisory ID: 17894
  • Bugtraq ID: 15720
  • Secunia Advisory ID: 18555
  • Other Advisory URL: go there
  • CVE ID: 2005-4065
  • FrSIRT Advisory: ADV-2005-2766

[ Vulnerabilities main page ]




The HNS Vulnerabilities section is powered by OSVDB


Spotlight

Attackers use reflection techniques for larger DDoS attacks

Posted on 17 April 2014.  |  Instead of using a network of zombie computers, newer DDoS toolkits abuse Internet protocols that are available on open or vulnerable servers and devices. This approach can lead to the Internet becoming a ready-to-use botnet for malicious actors.


Weekly newsletter

Reading our newsletter every Monday will keep you up-to-date with security news.
  



Daily digest

Receive a daily digest of the latest security news.
  

DON'T
MISS

Fri, Apr 18th
    COPYRIGHT 1998-2014 BY HELP NET SECURITY.   // READ OUR PRIVACY POLICY // ABOUT US // ADVERTISE //