Risks
Advisories
Browse
or
or
Gentoo Linux Security Advisory - PostgreSQL: Multiple vulnerabilities (GLSA 200703-15)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200703-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PostgreSQL: Multiple vulnerabilities
      Date: March 16, 2007
      Bugs: #165482
        ID: 200703-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PostgreSQL contains two vulnerabilities that could result in a Denial
of Service or unauthorized access to certain information.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  dev-db/postgresql      < 8.0.11                         >= 8.0.11
                                                            *>= 7.4.16
                                                            *>= 7.3.13

Description
===========

PostgreSQL does not correctly check the data types of the SQL function
arguments under unspecified circumstances nor the format of the
provided tables in the query planner.

Impact
======

A remote authenticated attacker could send specially crafted queries to
the server that could result in a server crash and possibly the
unauthorized reading of some database content or arbitrary memory.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose "dev-db/postgresql"

References
==========

  [ 1 ] CVE-2007-0555
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0555
  [ 2 ] CVE-2007-0556
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-0556

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200703-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Spotlight

eBook: Cybersecurity for Dummies

Posted on 16 December 2014.  |  APTs have changed the world of enterprise security and how networks and organizations are attacked. These threats, and the cybercriminals behind them, are experts at remaining hidden from traditional security while exhibiting an intelligence, resiliency, and patience that has never been seen before.


Weekly newsletter

Reading our newsletter every Monday will keep you up-to-date with security news.
  



Daily digest

Receive a daily digest of the latest security news.
  
DON'T
MISS

Fri, Dec 19th
    COPYRIGHT 1998-2014 BY HELP NET SECURITY.   // READ OUR PRIVACY POLICY // ABOUT US // ADVERTISE //