Risks
Advisories
Browse
or
or
Gentoo Linux Security Advisory - Perl: Multiple vulnerabilities (GLSA 201311-17)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201311-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Perl: Multiple vulnerabilities
     Date: November 28, 2013
     Bugs: #249629, #313565, #362025, #386357
       ID: 201311-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were found in Perl, the worst of which could
allow a local attacker to cause a Denial of Service condition.

Background
==========

Perl is Larry Wall's Practical Extraction and Report Language.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/perl              < 5.12.3-r1              >= 5.12.3-r1

Description
===========

Multiple vulnerabilities have been discovered in Perl. Please review
the CVE identifiers referenced below for details.

Impact
======

A local attacker could cause a Denial of Service condition or perform
symlink attacks to overwrite arbitrary files with the privileges of the
user running the application. A context-dependent attacker could cause
a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Perl users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/perl-5.12.3-r1"

References
==========

[ 1 ] CVE-2008-5302
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-5302
[ 2 ] CVE-2008-5303
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-5303
[ 3 ] CVE-2010-1158
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1158
[ 4 ] CVE-2011-0761
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0761
[ 5 ] CVE-2011-1487
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1487

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201311-17.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Spotlight

Targeted attack protection via network topology alteration

Posted on 17 October 2014.  |  This article from Trend Micro tackles how network topology can aid in defending the enterprise network from risks posed by targeted attacks.


Weekly newsletter

Reading our newsletter every Monday will keep you up-to-date with security news.
  



Daily digest

Receive a daily digest of the latest security news.
  

DON'T
MISS

Mon, Oct 20th
    COPYRIGHT 1998-2014 BY HELP NET SECURITY.   // READ OUR PRIVACY POLICY // ABOUT US // ADVERTISE //