Risks
Advisories
Browse
or
or
Gentoo Linux Security Advisory - Tor: Multiple vulnerabilities (GLSA 201301-03)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201301-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Tor: Multiple vulnerabilities
     Date: January 08, 2013
     Bugs: #432188, #434882, #444804
       ID: 201301-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Tor, allowing attackers to
cause Denial of Service or obtain sensitive information.

Background
==========

Tor is an implementation of second generation Onion Routing, a
connection-oriented anonymizing communication service.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-misc/tor                < 0.2.3.25               >= 0.2.3.25

Description
===========

Multiple vulnerabilities have been discovered in Tor. Please review the
CVE identifiers referenced below for details.

Impact
======

A remote attacker could cause a Denial of Service condition or obtain
sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Tor users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/tor-0.2.3.25"

References
==========

[ 1 ] CVE-2012-3517
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3517
[ 2 ] CVE-2012-3518
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3518
[ 3 ] CVE-2012-3519
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3519
[ 4 ] CVE-2012-4419
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4419
[ 5 ] CVE-2012-4922
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4922
[ 6 ] CVE-2012-5573
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-5573

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201301-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




Spotlight

What IT skills are in demand?

IT security tops the list of skills that teams need most, and one out of five reported having difficulty finding skilled talent for cloud initiatives. Companies are also looking for pros who have skills in network engineering, systems engineering, IT architecture and network operations.


Weekly newsletter

Reading our newsletter every Monday will keep you up-to-date with security news.
  



Daily digest

Receive a daily digest of the latest security news.
  
DON'T
MISS

Fri, Apr 17th
    COPYRIGHT 1998-2015 BY HELP NET SECURITY.   // READ OUR PRIVACY POLICY // ABOUT US // ADVERTISE //